链路聚合

2022-05-29T03:16:06.png
[AR1]interface Eth-Trunk1
[AR1-Eth-Trunk1]port link-type trunk
[AR1-Eth-Trunk1]port trunk allow-pass vlan 2 to 4094 //允许透传的VLAN
[AR1-Eth-Trunk1]load-balance src-dst-mac //配置Eth-Trunk接口基于源IP地址与目的IP地址进行负载分担

src-ip:配置Eth-Trunk接口基于源IP地址进行负载分担。
dst-ip :配置Eth-Trunk接口基于目的IP地址进行负载分担。
src-mac:配置Eth-Trunk接口基于源MAC地址进行负载分担。
dst-mac:配置Eth-Trunk接口基于目的MAC地址进行负载分担。
src-dst-mac:配置Eth-Trunk接口基于源IP地址与目的IP地址进行负载分担。
src-dst-mac:配置Eth-Trunk接口基于源MAC地址与目的MAC地址进行负载分担。

[AR1-Eth-Trunk1]quit
[AR1]interface GigabitEthernet0/0/1
[AR1-GigabitEthernet0/0/1]eth-trunk 1 应用在端口
[AR1-GigabitEthernet0/0/1]quit
[AR1]interface GigabitEthernet0/0/2
[AR1-GigabitEthernet0/0/2]eth-trunk 1
[AR1-GigabitEthernet0/0/2]quit
AR2亦是如此

MSTP配置

2022-05-29T04:05:45.png

[S1]stp instance 1 priority 4096 配置实例1优先级为4096
[S1]stp instance 1 root primary 配置实例1为树根
[S1]stp instance 2 priority 8192 配置实例1优先级为8192
[S1]stp instance 2 root secondary 配置实例2为备份根
[S1]stp mode mstp 设置生成树的模式是MSTP
[S1]stp enable 开启设备MSTP特性(默认不运行MSTP)
[S1]stp region-configuration 进入mst域配置模式
[S1-mst-region]region-name HQ 域名设置为HQ
[S1-mst-region]instance 1 vlan 12 to 13 配置VLAN映射表,将VLAN12 13 映射为实例1
[S1-mst-region]instance 2 vlan 14 to 15 配置VLAN映射表,将VLAN12 13 映射为实例1
[S1-mst-region]active region-configuration 激活mst域配置
[S1-mst-region]quit

ospf配置

#增加配置汇总

bandwidth-reference 1000 //修改OSPF计算度量值参考带宽为1000Mbit/s
silent-interface Vlanif 2  //且汇聚层的两个交换机只用vlan1来建邻,减小了路由表
silent-interface GigabitEthernet 0/0/1  //将连接接入层的接口调为静默接口,保证安全且不消耗链路资源
ospf进入area区域后 stub no-summary 完全末区域;stub设置为末梢区域;nssa设置为非完全末梢区域 三种模式根据题目输入
default-route-advertise  //将边界上的缺省路由通过五类LSA重发布入交换网络

2022-05-29T08:53:56.png

#一般配置

[sw1]ospf 1 router-id 1.1.1.1
[sw1-ospf-1]bandwidth-reference 1000 //修改OSPF计算度量值参考带宽为1000Mbit/s
[sw1-ospf-1]area 0
[sw1-ospf-1-area-0.0.0.0]network 172.16.0.2 0.0.0.0  //这里为了安全起见,将核心层的路由配置在骨干区域
[sw1-ospf-1]area 1
[sw1-ospf-1-area-0.0.0.0]network 172.16.2.0 0.0.0.255  //将接入层与汇聚层路由配置在区域1
[sw1-ospf-1-area-0.0.0.0]network 172.16.3.0 0.0.0.255
[sw1-ospf-1]silent-interface GigabitEthernet 0/0/1  //将连接接入层的接口调为静默接口,保证安全且不消耗链路资源
[sw1-ospf-1]silent-interface GigabitEthernet 0/0/2
[sw1-ospf-1]silent-interface Vlanif 2  //且汇聚层的两个交换机只用vlan1来建邻,减小了路由表
此处本应是两个接口都使用,一个用于建邻,一个用于备份建邻,如若有50个vlan,则需使用两个VLAN作为SVI接口来建邻,但本次实验的VLAN个数太少,所以就少用一个。

SW2与SW1一样配置

[r1]ip route-static 0.0.0.0 0 12.1.1.2  //由于需要交换网络访问ISP,所以需要在r1上配置到达ISP的缺省
[r1]ospf 1
[r1-ospf-1]default-route-advertise   //将边界上的缺省路由通过五类LSA重发布入交换网络

2022-05-29T09:08:51.png

SW2与SW1一样配置

#配置OSPF 特殊区域

将区域2配置为完全末节区域。

SZ
[SZ-ospf-1]area 2
[SZ-ospf-1-area-0.0.0.2]stub no-summary 完全末区域
BJ
[BJ-ospf-1]area2
[BJ-ospf-1-area-0.0.0.2]stub
S6
[S6-ospf-1]area 2
[S6-ospf-1-area-0.0.0.2]stub

#配置OSPF MD5验证。

[SZ]interface GigabitEthernet0/0/0
[SZ-GigabitEthernet0/0/0]ospf authentication-mode md5 1 cipher 123456

配置OSPF区域0的MD5验证
[SZ-ospf-1]area 0
[SZ-ospf-1-area-0.0.0.0]authentication-mode md5 1 cipher 123456

#OSPF路由聚合

[SZ-ospf-1]area 0
[SZ-ospf-1-area-0.0.0.0]abr-summary 10.1.12.0 255.255.252.0 //asbr 汇总外部路由
[SZ-ospf-1]area 1
[SZ-ospf-1-area-0.0.0.1]abr-summary 172.16.8.0 255.255.252.0
[SZ-ospf-1]area 2
[SZ-ospf-1-area-0.0.0.2]abr-summary 192.168.2.0 255.255.254.0

#控制OSPF DR选举

[SZ]interface GigabitEthernet0/0/2
[SZ-GigabitEthernet0/0/2]ospf dr-priority 2
[SZ]interface GigabitEthernet1/0/0
[SZ-GigabitEthernet1/0/0]ospf dr-priority 2

[SZ]interface GigabitEthernet0/0/1
[SZ-GigabitEthernet0/0/1]ospf timer hello 5
[SZ-GigabitEthernet0/0/1]ospf timer dead 20

#调整OSPF计时器

[BJ]interface GigabitEthernet0/0/1
[BJ-GigabitEthernet0/0/1]ospf timer hello 5
[BJ-GigabitEthernet0/0/1]ospf timer dead 20

DHCP配置

#全局通告模式

2022-05-29T13:47:51.png

#随机分配IP地址

ip pool 192
network 192.168.1.0 mask 24 //确定地址池的范围
gateway-list 192.168.1.254 //设置网关为 192.168.1.254
excluded-ip-address 192.168.1.2 //不参与自动分配的地址
lease day 1 hour 23 minute 59 //租期为1小时23分59秒
dns-list 8.8.8.8 //DNS
int g0/0/1
dhcp select global //选择全局的地址池给DHCP客户端

或者

#MAC分配ip地址

ip pool 172
network 172.16.1.0 mask 24 //确定地址池的范围
gateway-list 172.16.1.254 //设置网关为 192.168.1.254
static-bond ip-add 172.16.1.2 mac-add 5489-9822-2222 //分配172.16.1.2这个地址给MAC地址为5489-9822-2222的主机

中继路由
int g0/0/1
ip add 192.168.1.254 24
dhcp select relay //设置为中继模式
dhcp relay server-ip 10.1.12.1 //中继的服务器IP为10.1.12.1

#接口通告模式

dhcp enable
int vlan 2 此处是所选端口 或者VLAN
dhcp select interface
dhcp server dns-list 8.8.8.8 这是配置DNS的