基础配置:

sys sys LSW1 vlan batch 10 20 30 40 int g0/0/0

端口类型改为 access 添加VLAN为10

port link-type access port default vlan 10

端口类型改为trunk 允许通过VLAN 10 20 30

port link-type trunk port trunk allow-pass vlan 10 20 30

端口hybrid类型配置

[SWA-GigabitEthernet0/0/1]port link-type hybrid
[SWA-GigabitEthernet0/0/1]port hybrid tagged vlan 2 3 100 GigabitEthernet 0/0/1 只允许VLAN 2,VLAN 3和VLAN 100的带标签的数据帧通过。
[SWA-GigabitEthernet0/0/2]port hybrid pvid vlan 2
[SWA-GigabitEthernet0/0/2]port hybrid untagged vlan 2 100 GigabitEthernet 0/0/2在发送VLAN2和VLAN100的数据帧时会剥离标签。GigabitEthernet 0/0/3在发送VLAN3和VLAN100的数据帧时会剥离标签
[SWA-GigabitEthernet0/0/3]port hybrid pvid vlan 3
[SWA-GigabitEthernet0/0/3]port hybrid untagged vlan 3 100

此端口配置,满足了多个VLAN可以访问特定VLAN,而其他VLAN间不允许互相访问的需求。

配置回环接口 添加ip 192.168.1.1 24
[LSW1]int lo 0
[LSW1-LoopBack0]ip add 192.168.1.1 24

链路聚合:

手动链路聚合 编号为1

AR1:

int Eth-Trunk 1

trunkport g 0/0/0 to 0/0/1

port trunk allow-pass
port trunk allow-pass vlan all 这两条只能在int Eth-Trunk端口中配置

AR2亦是如此

LACP动态链路聚合

AR1:

int Eth-Trunk 1

mode lacp-static

AR2亦是如此

DHCP服务接口通告配置

dhcp enable
int vlan 2 此处是所选端口 或者VLAN
dhcp select interface
dhcp server dns-list 8.8.8.8 #这是配置DNS的

开启生成树协议

stp mode rstp 启动rstp服务

stp root primary 设置主根桥

stp root secondary 设置副根桥

stp priority 8192 设置优先级为 8192

OSPF配置

ospf 1 运行ospf 1

area 0 区域编号设置为 0

network 192.168.1.0 0.0.0.255 此处子网掩码为24 所以可用 0.0.0.255

network 10.1.1.0 0.0.0.3 此处子网掩码为30 所以可用 0.0.0.3

PPP 和 PAP 认证(aaa认证)

local-user huawei password cipher syh20072007 用户名都为 huawei,密码为 syh20072007
local-user huawei service-type ppp 启用此用户的 ppp认证

int s2/0/0
ip add 10.2.1.1 30
link-protocol ppp 启用此端口ppp认证

配置PAP认证(主验证方)

ppp authentication-mode pap

被验证方:

int s3/0/0
ip add 10.2.1.2 30
link-protocol ppp
ppp pap local-user huawei password cipher syh20072007

NAT 加 EASY-IP

acl 2002
rule permit source any 允许所有IP
q
int g0/0/0
nat outbound 2002 接入ACL 2002

VRRP配置

int vlan 2
vrrp vrid 2 virtual-ip 192.168.2.254 vrid 编号为2 虚拟IP为192.168.2.254
vrrp vrid 2 priority 200 vrid号为2的优先级为 200

优先级越大,越优先

vrrp vrid 2 track interface GigabitEthernet0/0/1 reduced 100

#跟踪上行链路的接口,出现故障后,自身降低优先级 100
如果存在备份路由器,就在那个路由器上一样配置就行

单臂路由配置

int g0/0/0.1 创建子接口

dot1q termination vid 10 配置VLAN ID 封装单层VLAN ID

ip add 192.168.1.1 24 添加ID

arp broadcast enable 启用子接口的ARP广播功能

snmp配置

题目:LSW3 实现集中管理,设置 snmp V3 管理协议,团体名为 2021,告警主机为192.168.2.252,使用用户 jsj,组号为 2020,mds 认证,密码为12345678,UDP端口为161,安全名为 2022

snmp-agent /*设置snmp集中管理

snmp-agent community write 2021 /*团体名为2021

snmp-agent sys-info version v3 /*设置snmp v3 管理协议

snmp-agent target-host trap address udp-domain 192.168.22.252 udp-port 161 params secruityname 2022

snmp-agent usm-user v3 jsj 2020 authentication-mode md5 12345678